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User Prompted to Install Mitchell Connect Desktop Agent When Already Installed, No Error in Diagnostics.

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TitleUser Prompted to Install Mitchell Connect Desktop Agent When Already Installed, No Error in Diagnostics.
SummaryGoogle Chrome user tries to export/download EMS/BMS but is prompted to install the desktop agent even though it's already installed, running, and up to date. Note: For MS Edge users experiencing this issue, locate article 000030480.
Symptoms

User is prompted to install the desktop agent when trying to export EMS even though the desktop agent is already installed, running, and up to date.

EnvironmentChrome, Mitchell Connect, Mitchell Cloud Estimating
Cause
A Google Chrome setting is blocking the loopback address (127.0.0.1) used by the Mitchell Connect Desktop Agent.   The setting involved was introduced with Chrome version 138.
Resolution
  1. Access the Mitchell Connect Sign In page, then sign in.
  2. Click the "View site information" icon to the left of the URL. 
  1. From the menu that displays, select Site Settings.
  2. Locate Local network access (near the bottom of the list).  Select Allow.
  3. Refresh Mitchell Connect then try to export EMS again.
Additional NotesIf Local Network Access is missing from Site Settings, Chrome requires updating. Navigate to Settings > About Chrome and it should begin the update automatically.
URL NameUser-Prompted-to-Install-Mitchell-Connect-Desktop-Agent-When-Already-Installed-No-Error-in-Diagnostics
Validation StatusValidated-Master

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